Technical Notes and Requirements

Java Support

The Java Runtime Environment version 5 (sometimes referred to as 1.5) or later with Java Webstart is required to run any of the activities. You can download it at: java.com.

Flash Support

Install Embedded Flash Support

WARNING: You need to install Firefox and the Adobe Flash Player for Firefox (if it is not already on your system) before clicking on the link above. To do this, install Firefox first and then revisit this page in a Firefox browser. When you click "Flash Player" above, it will install the correct version.